Degraded Performance

Major incident Internet Backbone Networking Gear SC2 Nodes [US] Los Angeles Hosted Email Nodes [US] Los Angeles Cloud Control Panel Compute Instance Management Dedicated Instance Management Email Instance Management CDN Instance Management DNS Instance Management Support Ticket Management Payment Processing Cloud View API Website
Jul 28 (Tue), 2020 10:53 AM UTC · 2 hours, 17 minutes

Updates

Resolved

Marking issue as resolved

November 4, 2021 · 03:24 PM UTC
Monitoring

Case resolved, network should be back to normal. We will be monitoring this for another hour.

November 4, 2021 · 03:24 PM UTC
Investigating

The network issue is still being investigated. We are awaiting updates from our partner datacenter in LA, USA, as they work on the case.

It appears to be a DDoS attack, as multiple switches are currently being affected.

November 4, 2021 · 03:24 PM UTC
Issue

We have identified a performance degradation on <strong>our network</strong>, some clients are experiencing intermittent timeouts.

Our network engineers and sysadmins are investigating the issue at the moment.

Further findings and updates shall be updated on this status page.

November 4, 2021 · 03:24 PM UTC

← Back