[HS114] Hypervisor Outage
Minor incident
VPS Nodes
[US] Los Angeles
Sep 30 (Tue), 2025 07:56 PM UTC
· 12 hours, 52 minutes
Updates
Resolved
October 1, 2025 · 08:47 AM UTC
The RAID 10 array on the server experienced a degradation event. The issue was identified, and the degraded array was promptly replaced. Following the replacement and verification of system stability, the affected node has been brought back online and is now operating normally.
Issue
September 30, 2025 · 07:56 PM UTC
We have identified an outage on our HS114 node, Virtual instances on this specific node should see network timeouts.
Our network engineers and sysadmins are investigating the issue at the moment.
Further findings and updates will be updated on this status page.
← Back