VPS Management Returns 404

Minor incident Cloud Control Panel VPS Instance Management
Jan 19 (Mon), 2026 03:11 PM UTC · 2 hours, 6 minutes

Updates

Resolved

The issue causing the VPS management page to return a 404 error in the client area has now been resolved.

Clients can access and manage their VPS services normally. We apologize for the inconvenience caused and appreciate your patience while the issue was addressed.

January 19, 2026 · 05:17 PM UTC
Issue

An incident was identified where the VPS management page in the client area returns a 404 Not Found error when accessed. Affected clients are unable to view or manage their VPS services through the client portal.

Core VPS services remain operational; however, management functions via the client area are currently inaccessible. The issue has been escalated for investigation and resolution, and updates will be provided as progress is made.

January 19, 2026 · 03:11 PM UTC

← Back