[S226-V] Hypervisor Outage

Minor incident VPS Nodes [US] St. Louis
Feb 23 (Mon), 2026 03:29 PM UTC · 6 minutes

Updates

Resolved

Issue marked as resolved

February 23, 2026 · 03:35 PM UTC
Issue

We have identified an outage on our S226-V node, Virtual instances on this specific node should see network timeouts.

Our network engineers and sysadmins are investigating the issue at the moment.

Further findings and updates will be updated on this status page.

February 23, 2026 · 03:29 PM UTC

← Back