Service Outage

Major incident Internet Backbone
2020-12-09 07:34 UTC · 1 hour, 28 minutes, 37 seconds

Updates

Resolved

The issue has been resolved. The network has been restored to its original state, we thank you for your corporation and understanding on this incident.

December 9, 2020 · 09:02 AM UTC
Monitoring

Services are back online. We’re gathering information with our data center regarding this incident at the moment.

December 9, 2020 · 08:17 AM UTC
Investigating

This outage is related to our upstream provider’s network (Multacom, Los Angeles) We’re working closely with our upstream to resolve the network as we speak.

December 9, 2020 · 08:07 AM UTC
Monitoring

We have identified an outage on our services, at this stage, some services should be facing network timeouts and degraded performance.

Our network engineers and sysadmins are investigating the issue at the moment.

Further findings and updates will be updated on this status page.

December 9, 2020 · 07:34 AM UTC

← Back