Service Outage

Major incident SC2 Nodes [US] Los Angeles Hosted Email Nodes [US] Los Angeles
Apr 05 (Mon), 2021 05:47 AM UTC · 10 minutes

Updates

Resolved

Issue has been resolved. Monitoring will be in place

November 4, 2021 · 03:25 PM UTC
Issue

We have identified an outage on our services, at this stage, some services should be facing network timeouts and degraded performance.

Our network engineers and sysadmins are investigating the issue at the moment.

Further findings and updates will be updated on this status page.

November 4, 2021 · 03:25 PM UTC

← Back